Thursday, November 21, 2013

RIP(part II)

Last time, we already learn about RIPv1. in this section, we will learn about RIPv2.
Characteristic of RIPv2:
- RIPv2 is a Distance Vector Routing Protocol.
- RIPv2 is a classless routing protocol (Support VLSM, CIDR and Supernet)
CIDR -> Class Inter Domain Routing
CIDR is a technic to combine a few route become one route, to save routing table and traffic for routing update
- RIPv2 is also using UDP with port 520
- RIPv2 using hop count for the metric
- Max Hop in RIPv2 is 15. 16 is unreachable
- Administrative Distance in RIPv2 is 120
- RIPv2 need 30second to update by multicast (224.0.0.9)
- By default, RIPv2 do automatic summarization to become classless
- RIPv2 had Feature Authentication to enable password for using RIP
In RIPv2 had a loopback interface.
Loopback interface is an interface that working virtual, to simulate a network. (didn’t need to no shut, because by default is already up).
by command
Router(config)#interface loopback
Router(config-if)#ip address
By default, cisco router didn’t enable RIPv2. to enable, u must use command version 2.
Router(config)#router rip
Router(config-router)#version 2
In RIPv2, is also had a Null Interface.
Null Interface is an Exit Interface by virtual, usually being used to distribute static route summary in routing protocol.
This interface will not do data forward, so the package that come in this interface will be drop.
command:
ip route 192.168.0.0 255.255.0.0 null 0
Redistribute static is usually use for distribute to static route to directly connected routes.
to use redistribute static route, we can use command:
Router(config-route)#redistribute static
Ok. Now we are going to do practice RIPv2
In this section, i will not describe a full detail information for this topology network.
But i will give the configuration below.
First we go to router1
Router>en
Router#conf t
Router(config)#interface fastEthernet 0/1
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#ex
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 10.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#ex
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#network 192.168.1.0
Router(config-router)#network 10.0.0.0
Router(config-router)#ex
Router(config)#ex
After finished configured router 1, now we go to router 2
Router>en
Router#conf t
Router(config)#interface fastEthernet 0/1
Router(config-if)#ip address 172.16.0.1 255.255.0.0
Router(config-if)#no shutdown
Router(config-if)#ex
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 10.0.0.2 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#ex
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#network 10.0.0.0
Router(config-router)#network 172.16.0.0
Router(config-router)#ex
Router(config)#ex
To check your configuration is already correct or not. you can try to ping.

0 comments:

Post a Comment