Thursday, November 21, 2013

RIP (part I)

Right now we will discuss about RIP(Routing Information Protocol).
There are two type of RIP that being used.
That is RIPv1 and RIPv2.
In this part, we will discuss about RIPv1 and example exercise about how to using RIPv1.
RIPv1
Below is the Characteristic RIPv1:
- RIPv1 is a distance vector routing protocol
- RIPv1 use hop count as metric
- RIPv1 is a classful routing protocol
- max hop count in RIPv1 is 15. if 16, it means unreachable.
- RIPv1 send periodic update every 30 second with broadcast
- RIPv1 using protocol UDP with port 520
- RIPv1 by default running auto-summary
- RIPv1 can send packet update RIPv1 and receive packet update RIPv1 & RIPv2
- In Cisco, RIPv1 have AD (Administrative Distance) 120.
When installation, router-router that running RIP will broadcast packet request to another router to ask network that another router have.
Another Router will receive request packet and sending response.
After that they will sharing each network information.
to enable RIP, we can use command:
config#router rip
to add directly connected network that will being broadcast, we can use command:
config-router# network {classful-network-address |network address}
this command can be input after we enable RIP first.
In RIPv1, there are passive interface.
Passive interace is an interface that being participate but didn’t send any update.
to create passive-interface, we can use command
config-router#passive interface
this command can be input after we enable RIP first.
Right now we will learning update algorithm for RIPv1
1.Sending Update
RIPv1 will compare major network info with major network sending interface.
if same:
RIPv1 will check SubnetMask(SM) info with sending interface SubnetMask.
if check SM infor with sending interface SM same, RIPv1 will send the info, otherwise it will not send
otherwise:
RIP will summarize info into it’s major
2.Receiveng update
RIP will compare between network info with major network receiving interface
if same RIP will install with SM interface.
Otherwise RIP will check if major network info is same with each directly connected major network
if there is a same major network, RIPv1 will not install(discontigous), otherwise it will install with SM default class
Major network is same with classfull SM
Automatic summarization.
In RIP, it also have characteristic Automatic summarization
The Advantages for Automatic summarization is automatic and simple.
The Disadvantages:
- If network using VLSM, the RIP can’t be convergence
- If discontigous, network can’t be convergence
- load balancing could be wrong
Below we will practice for case RIPv1
please click to enlarge the picture
Picture Information
Router1(Router_ATD)
fa 0/0 : 172.16.0.1 /24
serial 2/0 : 172.16.1.1 /30
Router2(Router_ISB)
fa0/0 : 192.168.3.1 /24
Serial 2/0 : 172.16.1.2 /30
serial 3/0 : 10.0.0.1 /30
Router3(Router_LHR)
fa 0/0 : 192.168.4.1 /24
serial 2/0 : 10.0.0.2 /30
now lets begin the configuration
first we go to Router1
Router> en
Router#configure terminal
Router(config)#hostname Router_ATD
Router_ATD(config)#interface fastEthernet 0/0
Router_ATD(config-if)#ip address 172.16.0.1 255.255.255.0
Router_ATD(config-if)#no shutdown
Router_ATD(config-if)#exit
Router_ATD(config)#
Router_ATD(config)#interface se2/0
Router_ATD(config-if)#ip address 172.16.1.1 255.255.255.252
Router_ATD(config-if)#no shutdown
Router_ATD(config-if)#exit
Router_ATD(config)#router rip
Router_ATD(config-router)#network 172.16.0.0
Router_ATD(config-router)#network 172.16.1.0
Router_ATD(config-router)#no auto-summary
Router_ATD(config-router)#passive interface fa0/0
Router_ATD(config-router)#exit
we use command no auto-summary because in this topology didn’t need auto summary.
for command passive interface fa 0/0, this command is to make fa0/0 didn’t send update routing table from fa 0/0 and still get update routing table from another router.
command
Router_ATD(config-router)#network 172.16.0.0
Router_ATD(config-router)#network 172.16.1.0
is to add network from directly connected network.
now we go to router 2
Router> en
Router#configure terminal
Router(config)#hostname Router_ISB
Router_ISB(config)#interface fastEthernet 0/0
Router_ISB(config-if)#ip address 172.168.3.1 255.255.255.0
Router_ISB(config-if)#no shutdown
Router_ISB(config-if)#exit
Router_ISB(config)#
Router_ISB(config)#interface se2/0
Router_ISB(config-if)#ip address 172.16.1.2 255.255.255.252
Router_ISB(config-if)#no shutdown
Router_ISB(config-if)#exit
Router_ISB(config)#interface se2/0
Router_ISB(config-if)#ip address 10.0.0.1 255.255.255.252
Router_ISB(config-if)#no shutdown
Router_ISB(config-if)#exit
Router_ISB(config)#router rip
Router_ISB(config-router)#network 192.168.3.0
Router_ISB(config-router)#network 172.16.1.0
Router_ISB(config-router)#network 10.0.0.0
Router_ISB(config-router)#no auto-summary
Router_ISB(config-router)#passive interface fa0/0
Router_ISB(config-router)#exit
let us begin with Router 3
Router> en
Router#configure terminal
Router(config)#hostname Router_LHR
Router_LHR(config)#interface fastEthernet 0/0
Router_LHR(config-if)#ip address 192.168.4.1 255.255.255.0
Router_LHR(config-if)#no shutdown
Router_LHR(config-if)#exit
Router_LHR(config)#
Router_LHR(config)#interface se2/0
Router_LHR(config-if)#ip address 10.0.0.2 255.255.255.252
Router_LHR(config-if)#no shutdown
Router_LHR(config-if)#exit
Router_LHR(config)#router rip
Router_LHR(config-router)#network 10.0.0.0
Router_LHR(config-router)#network 192.168.4.0
Router_LHR(config-router)#no auto-summary
Router_LHR(config-router)#passive interface fa0/0
Router_LHR(config-router)#exit
To prove it, u can try ping from one router to other router.
Hope this can help u to understand more about RIPv1.

0 comments:

Post a Comment